Jump to content


Photo

[GUIDE] Run AngelsMu and Computer Requirements


  • Please log in to reply
85 replies to this topic

#1 Lightning

Lightning

    JmLighT

  • Administrators
  • 11504 posts
  • LocationCanada

Posted 22 May 2014 - 04:35 AM

Hello,
 
If you have issues with running AngelsMu please refer to the below information.
 

Any MU Server Computer Requirements

 
Operating System - Windows XP or Windows 7/8
 
Processor - Pentium 4 – 2.0 Ghz or Higher
 
System Memory - 1 GB or Higher
 
Video Card - 3D Graphics processor
 
DirectX Version - DirectX 9.0 or higher
 
Hard Disk Space - 2 GB or Higher
 
Update Required - PC and it's drivers
 
Internet Connection - Average
------------------------------------------------------------------------------------------
 
For Season 8 Server - At least double from what you see in the above requirements.
 
If you are running multiple AngelsMu client - 1 or 2 GB System Memory / RAM is not enough. You will need at least 4 GB or Higher to run at least 2 AngelsMu windows WITHOUT LAG.
 
If you are experiencing LAG with good PC then I suggest you to contact your net provider. AngelsMu Server is hosted in one of the best data centres in the world. Speed to every countries and ping is good. Even it is bad; we can't do anything about is as your net connection issues can only be resolve by your internet provider.
-----------------------------------------------------------------------------

 
If you get disconnected constantly.
 

First, try to disable anti-virus/firewall/windows defender.
 
If nothing works then try below:
 
Download and Install Net Framework 4 at http://www.microsoft...s.aspx?id=17851 - just follow the steps..
 
Update your PC and its drivers..
 
If nothing works after that then
 
Try to run main exe. in compatibility mode....
 
If that doesn't work then try this..
 
Right Click on My Computer
 
Click Advance System Settings
 
Click on Settings (Performance)
 
Go to Tab Data Execution Prevention
 
Click the 2nd circle to Turn ON DEP
 
Click ADD
 
Add the AngelsMu main.exe
 
Then click OK / Apply
 
Restart PC

 
Having msvcp110.dll or any .dll errors?

 
You need to uninstall your current Microsoft Visual C++ and re-download and re-install the most recent version that fits to your computer compatibility.
 
This website: http://support.micro....com/kb/2019667 - will give you the most accurate and latest versions for Microsoft Visual C++
 
For example: My PC is x64 bit. When I downloaded 2010 Microsoft Visual C++ 64bit it did not work but instead I downloaded 2010 Microsoft Visual C++ x86 and all servers worked especially Mu.PlayGlobal and MuWars.
 
After installing Microsoft Visual C++ in to your PC then I suggest you to perform "Windows Update". 
 
After windows update, fully restart your PC and try main.exe as Administrator or Launcher (if available).
 
Note: If .DLL error still persist then I suggest you to uninstall ALL Microsoft Visual C++ and test the most latest version first then work your way down to 2010. 
 
For example: You downloaded and installed 2012 and 2010 Microsoft Visual C++ in to your computer but your MU still doesn't work. All you need to do is uninstall ALL Microsoft Visual C++ and re-download 2012 version first. If 2012 doesn't work then uninstall 2012 and re-install 2010. (Keep in mind that x86 might work to any x32bit or x64bit PC's so keep testing until you find the most compatible version for your PC.)
 
Thread is still incomplete - will complete this thread with pictures soon.

 

Follow this guide to help you with resolving .DLL issues: http://forum.angelsm...62&hl=microsoft
 
Cheers,
Jared


  • apophys likes this

Spoiler

#2 apophys

apophys

    Master Corporal

  • Banned
  • PipPip
  • 134 posts

Posted 23 May 2014 - 12:46 PM

Processor - Pentium 4 – 2.0 Ghz or Higher

 

System Memory - 1 GB or Higher

so for season 8 to run 1 main i need more then 2.0ghz processor ? and 2 GB ram ? ty and gl

 


#3 Lightning

Lightning

    JmLighT

  • Administrators
  • 11504 posts
  • LocationCanada

Posted 23 May 2014 - 02:11 PM

Processor - Pentium 4 – 2.0 Ghz or Higher

 

System Memory - 1 GB or Higher

so for season 8 to run 1 main i need more then 2.0ghz processor ? and 2 GB ram ? ty and gl

 

---------------

 

If you want a better game play then yes... 

 

Maybe it will run with the basic requirements but you may get DC a lot and your game play would suck..

 

2GB RAM for 1 AngelsMu client should be enough. If you plan on opening more clients then you will laggg..

 

Cheers,

Jared


  • apophys likes this

Spoiler

#4 Bupyc

Bupyc

    Master Corporal

  • Members
  • PipPip
  • 124 posts
  • LocationNorwich, United Kingdom

Posted 23 May 2014 - 08:19 PM

I dont know if you really need that much requirements, because mu ever since it was first released didnt require a lot from the system, and though it was upgraded throughout the years, the system requirements went up only a little bit. 

 

 

2GB RAM for 1 AngelsMu client should be enough. If you plan on opening more clients then you will laggg..

 

Not sure about this one either, I currently have 8GB RAM and I can play 5 windows no lags. The only issue is when I try to do PvP with more than 1 window, the game kinda glitches for a bit and then restores. If thats the lag you are talking about, I dont think that increasing RAM would solve this issue :P


My main chars x750

 

[WeedMage][RastaWar][SneakyElf]

 

cherry_fields_color_zpsc1ed8e78.jpg

AMAZING VISUALIZER


#5 Lightning

Lightning

    JmLighT

  • Administrators
  • 11504 posts
  • LocationCanada

Posted 23 May 2014 - 08:31 PM

I dont know if you really need that much requirements, because mu ever since it was first released didnt require a lot from the system, and though it was upgraded throughout the years, the system requirements went up only a little bit. 

 

 

 

Not sure about this one either, I currently have 8GB RAM and I can play 5 windows no lags. The only issue is when I try to do PvP with more than 1 window, the game kinda glitches for a bit and then restores. If thats the lag you are talking about, I dont think that increasing RAM would solve this issue :P

--------------

 

Honestly, I don't own such low level specs computer so I wouldn't know. 

 

Most of my computers have 16GB with 300+ MBPS speed so I wouldn't experience any lags at all.

 

I asked the Admin and he confirmed that the requirements to run Season 8 is doubled from the basic requirements. 

 

I guess I am referring to any kinds of lags and not just 1. LOL

 

This post was meant to help understand  that if you have such low specs PC with bad net connection then you will get lag eventually not to mention people uses 2 GB and also running different programs so possible they could be lag too. Who knows right? LOL

 

Cheers,

Jared


Spoiler

#6 Skire

Skire

    Applicant

  • Members
  • 4 posts

Posted 27 May 2014 - 04:05 AM

Had mscvp100.dll error
Followed the tutorial of the forum to fix it but now, when i try to start the game, it just pop up and instaclose the game.

I played other mu online servers before so i dont  know why this is happening to me



#7 SnowMakeR

SnowMakeR

    Master Corporal

  • Members
  • PipPip
  • 133 posts
  • Locationthessaloniki greece

Posted 27 May 2014 - 09:13 AM

Had mscvp100.dll error
Followed the tutorial of the forum to fix it but now, when i try to start the game, it just pop up and instaclose the game.

I played other mu online servers before so i dont  know why this is happening to me

check any malwares/virus programs,make exception for the game ;)

 

 

I dont know if you really need that much requirements, because mu ever since it was first released didnt require a lot from the system, and though it was upgraded throughout the years, the system requirements went up only a little bit. 

 

 

 

Not sure about this one either, I currently have 8GB RAM and I can play 5 windows no lags. The only issue is when I try to do PvP with more than 1 window, the game kinda glitches for a bit and then restores. If thats the lag you are talking about, I dont think that increasing RAM would solve this issue :P

The first version are just simple in coding(java aplet) and dindt require a lot of specs,but after s4 the game requires 3d renderring and lost of gpu are lacking of this or 3d shadows render,so yes the new games as s8 update requires lots of requirement.

My suggestion for playing now is:

 

Cpu intel seriers 4 or amd athlon 2500 and higher

 

Gpu internal geforce 1200 or higher

Gpu external geforce 6200 and higher

 

Memory 1gb and higher

 

Net speed 4mb and higher.

 

Directx 9

 

Netframework 3.5

 

Windows xp and higher

 

Thats the simple requirements to run the game but with medium low graphics and glitches for one or 2 clients

 

As i search in official i come with some requirements for s8 and those are:

 

Cpu core duo or higher

(for multi clients i3 and higher)

 

Gpu internal 2600 and higher

Gpu external gt 2 series and higher

 

Memory 6gb and higher

(pair of memory`s are better for double or triple channel)

 

Netframework 4.0

 

DirectX 10 and higher

 

LATEST java updates

 

Net speed more than 8mb



#8 Skire

Skire

    Applicant

  • Members
  • 4 posts

Posted 28 May 2014 - 03:42 AM

i meet all the requirements
i recently format my pc (i have net framework and all these things)
im playing other servers perfectly, this server i cant
i dont have to make any exception cuz my firewall is deactivated at the moment
there is no malware on my pc.

I dont know what to do xD



#9 SnowMakeR

SnowMakeR

    Master Corporal

  • Members
  • PipPip
  • 133 posts
  • Locationthessaloniki greece

Posted 28 May 2014 - 09:57 PM

i meet all the requirements
i recently format my pc (i have net framework and all these things)
im playing other servers perfectly, this server i cant
i dont have to make any exception cuz my firewall is deactivated at the moment
there is no malware on my pc.

I dont know what to do xD

 

Can you plz tell me your specs of pc?



#10 Skire

Skire

    Applicant

  • Members
  • 4 posts

Posted 29 May 2014 - 07:18 AM

Can you plz tell me your specs of pc?

Operating System - Windows 7 actually (windows 8 before i format)

 

Processor - intel i3

 

System Memory - 4 GB 

 

Video Card - 3D Graphics processor ATI radeon hd series 4550 (not that good but enough)

 

DirectX Version - DirectX 9.0 or higher (11 maybe, dont remember)

 

Hard Disk Space - 512gb (more than 380gb of free space atm)

 

Update Required - PC and it's drivers ... its all updated

 

Internet Connection - 10mbs



#11 SnowMakeR

SnowMakeR

    Master Corporal

  • Members
  • PipPip
  • 133 posts
  • Locationthessaloniki greece

Posted 29 May 2014 - 09:25 AM

If you have install the net framework make secon install of other version aka if you install the x64 version make second install x86 version without uninstall the first one

search for java software and install it on your system.

Give the program administrator privilige



#12 Skire

Skire

    Applicant

  • Members
  • 4 posts

Posted 29 May 2014 - 05:22 PM

If you have install the net framework make secon install of other version aka if you install the x64 version make second install x86 version without uninstall the first one

search for java software and install it on your system.

Give the program administrator privilige

same problem. doesnt work :/



#13 SnowMakeR

SnowMakeR

    Master Corporal

  • Members
  • PipPip
  • 133 posts
  • Locationthessaloniki greece

Posted 29 May 2014 - 11:30 PM

Last hope is to reinstall the game



#14 jadewer20

jadewer20

    Applicant

  • Members
  • 4 posts

Posted 10 June 2014 - 02:47 AM

Already tried the thread but still the same and i also disabled my firewall and antivirus.....I always get d/c few minutes from playing the game already tried reinstalling thrice..disabling the firewall and antivirus did worked a little bit i did play for longer minutes but still got d/c....thanks



#15 jadewer20

jadewer20

    Applicant

  • Members
  • 4 posts

Posted 10 June 2014 - 03:36 AM

well not moving from a spot of monsters does not d/c me but when i move to another spot or teleport to hunt monster still disconnect me from the game.. I hope u admin could help me cuz i really love the game..thanks



#16 Lightning

Lightning

    JmLighT

  • Administrators
  • 11504 posts
  • LocationCanada

Posted 10 June 2014 - 07:17 PM

Already tried the thread but still the same and i also disabled my firewall and antivirus.....I always get d/c few minutes from playing the game already tried reinstalling thrice..disabling the firewall and antivirus did worked a little bit i did play for longer minutes but still got d/c....thanks

 

well not moving from a spot of monsters does not d/c me but when i move to another spot or teleport to hunt monster still disconnect me from the game.. I hope u admin could help me cuz i really love the game..thanks

------------

 

Double posting is not allowed here so consider this a warning.

 

Which spot? Give map and coordinates.

 

Which skill are you using?

 

What's your stats? Show me a screenshot of your "C" Character information and "A" skill tree (if you completed 3rd quest)

 

Cheers,

Jared


Spoiler

#17 jadewer20

jadewer20

    Applicant

  • Members
  • 4 posts

Posted 12 June 2014 - 11:32 AM

no specific spot as long as i move to another spot and teleport to another place i got d/c my stats is full in vit, ene and str for agi its 7k... Im using twisting slash...sorry for double posting i dont know that rule...



#18 Lightning

Lightning

    JmLighT

  • Administrators
  • 11504 posts
  • LocationCanada

Posted 13 June 2014 - 03:52 PM

no specific spot as long as i move to another spot and teleport to another place i got d/c my stats is full in vit, ene and str for agi its 7k... Im using twisting slash...sorry for double posting i dont know that rule...

-------------

 

Forwarded to Admin.

 

Cheers,

Jared


Spoiler

#19 rzvn2012

rzvn2012

    Private Basic

  • Members
  • Pip
  • 14 posts

Posted 23 June 2014 - 02:08 PM

First I had the mscv110.dll error,now when i start the game it pops-up and then closes instantly, any solve for this?

 

L.E: tried reinstall,not working



#20 Lightning

Lightning

    JmLighT

  • Administrators
  • 11504 posts
  • LocationCanada

Posted 23 June 2014 - 10:43 PM

First I had the mscv110.dll error,now when i start the game it pops-up and then closes instantly, any solve for this?

 

L.E: tried reinstall,not working

------------------

 

Did you try doing this step:

 

First, try to disable anti-virus/firewall/windows defender.

 

If nothing works then try below:

 

Download and Install Net Framework 4 at http://www.microsoft...s.aspx?id=17851 - just follow the steps..

 

Update your PC and its drivers..

 

If nothing works after that then

 

Try to run main exe. in compatibility mode....

 

If that doesn't work then try this..

 

Right Click on My Computer

 

Click Advance System Settings

 

Click on Settings (Performance)

 

Go to Tab Data Execution Prevention

 

Click the 2nd circle to Turn ON DEP

 

Click ADD

 

Add the AngelsMu main.exe

 

Then click OK / Apply

 

Restart PC

 

Cheers,

Jared


Spoiler




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users